Imx Fix in my experience
 
« prev next »

November 5, 2002 9:43 AM


About two years ago I began adding a line to the Functional Requirements Documents I was writing that said something like...
Supporting Netscape Navigator 4.x represents a technical and business risk to the success of the Business Plan.
The reason I would add this is that double coding JavaScript routines, or using wrapper functions, represented a doubling in development time, resulting in increased costs to the client and a extended delivery times. Time is money.

This morning, I realized that my warning can and should contain another comment...

Supporting Netscape Navigator 4.x (Nav4) represents a technical and business risk to the success of the Business Plan. Implementing support for Nav4 will decrease the durability of the application be increasing the amount of code to maintain and the complexity of that code, for a browser that is rapidly falling off the browsing landscape.
Unfortunately, I still get projects where the question "who is the user base?" gets answered with, "Solaris users with Nav4." I'm at the point in my front end development career that those words anger me.